Skip to content

Cisco – Como configurar servidor DHCP

Neste artigo passo a explicar como configurar servidor DHCP nos routers Cisco, nao vou dar grade importancia ao funcionamento do DHCP para isso consulte o tutorial sobre DHCP aqui.

Como sabemos um servidor DHCP atribui endereços IP de forma dinamica a uma interface

Configurar servidor DHCP

Entrar em modo privilegiado

Router> enable

Configurar terminal

Router# config terminal

Configurar IP na interface fe0/0

Router(config)# interface fa 0/0
Router(config-if)# ip address 192.168.0.1 255.255.255.0
Router(config-if)# no shutdown

CISCO DHCP

Activar serviço na interface

Router(config)# service dhcp

Criar pool DHCP com o nome segwebPool

ip dhcp pool <pool name>
Router(config)# ip dhcp pool segwebPool

Atribuir endereço de rede e mascara

network <network address> <subnet mask>
Router(dhcp-config)# network 192.168.0.0 255.255.255.0

Atribuir nome de domínio

domain-name <domain-name>
Router(dhcp-config)# domain-name segweb.local

Atribuir Gateway padrão

default-router <ip address>
Router(dhcp-config)# default-router 192.168.0.1

Atribuir servidores DNS (google)

dns-server <ip address1> <ip address2>
Router(dhcp-config)# dns-server 8.8.8.8 8.8.4.4

//Atribuir IP WINS server

netbios-name-server <WINS Server IP address>
Router(dhcp-config)# netbios-name-server 192.168.0.3

Especificar um lease de 4 horas

lease <days> <hours> <minutes>
Router(dhcp-config)# lease 0 4 0

Sair do modo de configuração DHCP

Router(dhcp-config)# exit

Excluir endereços IP da pool

Sintaxe : ip dhcp excluded-address <starting ip address> <ending ip address>

Router(config)# ip dhcp excluded-address 192.168.0.1 192.168.0.2

Parte 2

Mais comandos uteis para admistração

Verifica IP’s ja atribuidos

Router# show ip dhcp binding
show ip dhcp conflict

Lista eventuais conflitos de endereços IP.

show ip dhcp database

Lista o DHCP database.

show ip dhcp pool

Lista todo o conteúdo dos pools configurados.

show ip dhcp relay information trusted-sources

Lista as informações sobre o relay DHCP.

show ip dhcp server statistics

Mostra as estatísticas do tráfego DHCP.

debug ip dhcp server events

mostrar os “empréstimos” e “expirations” dos endereços IP.

debug ip dhcp server linkage

Diagnostica eventos em situações onde existem relações entre dois ou mais servidores DHCP

debug ip dhcp server packet
Published inGeralProtocolosRedes
Newsletter Signup

Subscribe to our weekly newsletter below and never miss the latest product or an exclusive offer.